Viliv X70 Ex 

 

Included

  • Car windshield holder.
  • Atom Silverthorne 1.33GHz
  • 32 GB SSD
  • 12v cigarette lighter adapter
  • Interesting Case, its a two sided affair with an alternative stylus inside a fancy red interior (which has a rather pungent smell). It is designed by GearGuard, and tells me ‘caution’, ‘zoom’ no idea what that is all about, though I’m reminded of Kryten from Red Dwarf being surprised humans don’t have a zoom function. ‘rotate 60’CCW’ (on) ‘rotate 60’’ CW’ (off).
  • Power supply with US adapter ( can be switched out, but only has US one) 9.5V 2.84A centre positive.
  • Small manual (which has notes to refer to the detailed manual, the box looks like it was designed for a large manual but no such device, probably a PDF at Viliv/dynamism or on disk somewhere.
  • Mini USB Cable, which apparently is for connecting to a ‘terminal computer’, and I’m to refer to the detailed manual.
  • Windows XP Home edition.
  • Two stick on glossy screen protectors.
  • Battery claimed 5.5 hours.

 

Day 1 Rambling notes…..

My Viliv just arrived from dynamism.com, unpacked it put the protective layer on the screen, plugged it in and booted it up, first thing it does is lock up when the CubeUI appears.. Seems like the display is frozen since the power switch still works and windows will close down, but no mouse or side buttons.

DSC01973

Cube UI

image

 

Have to dig out a USB keyboard to see if a nerve pinch will do it. USB Keyboard connected, seems like the  touch screen doesn’t work, it did allow me to run the XP setup then no more. The WLAN doesn’t seem to be working either, and when i plugged in a USB keyboard the Bluetooth notification icon said the BT hardware had been removed.

A couple of reboots and the touch screen seems to be working, the BT hardware keeps adding and removing though. Needs a 4 point calibration straight away as its way off out of the box. TouchSide is the name of the app that handles it, looks like the same software that goes with the Xenarc touch screens.

 

The supplied protective film is about 2mm short of the entire width, which is a little annoying since if you’re drawing on the edge of the screen (art rage) or testing the calibration the touch pen gets stuck, not a big deal it’ll be hard to get protective screens that are an exact fit. Like the Sony Vaio TR , which has an excellent tabbed design instead of sticking it to the screen which has all sorts of issues, you can also easily change out to privacy filters.

 

The car window holder seems ok except for the latching mechanism seems a bit on the loose side. I’ve got a feeling its either shonky or somehow its slipped out from where it ought to be located, as its very loose and doesn’t take much for it to move to the unlocked position at which point the Viliv would fall out, especially on a car. I’ll be finding out if RAM make a better mount or if there is something up.

DSC01980

 

Update: I decided this thing just can’t be as bad as it appears, so i removed the CPU, loosened, not remove, the two small screws holding the lever on the windshield adapter, rotated the lever to point up ( between the two bumps ) and retightened the screws, and voila it works properly, the lever notches itself into one of the bumps and it locks a lot more securely. So as i suspected something was up.

 

 

Suddenly as if by magic after testing the touch screen draw tool the wireless adapter has appeared and sprung to life, however its not showing any of my networks, even though the router is about 2 meters away. After a few refreshes the router thats at the other end of the house shows up.

Typed in the WPA2 key and it starts to connect, I’ll run it through windows update. 31+ updates, I’m not installing IE8 for now  since I’ve had issues with it being very slow on the Atom. I have been using Safari a lot recently though, its really quick. The bluetooth hardware is still switching on and off, so it might be loose or just weird.

 

Since I’m on a glass table, I’ll use the car mount. The locking tab on the car adapter is either out of place, missing something obvious or its just simply terrible, even swinging the unit from left to right disengages.

 

The screen with protector is very glossy, my use for this device is in car so it’ll probably have to be replaced and I’ll see if I can find a matte one,  the iPhone has them so they’re around. Screen quality wise it seems about the same as my Vaio UX180P which is OK, just a bit dull, the brightness is preset to 50% so upping it helps a bit, but I just don’t care for glossy screens.

Power wireless, and HDD lights are on the top, facing up, so you can’t see them from the front. A small detail but could be easily fixed with a notch in the front display, or a slightly raised bump. I knocked out the power connector when inspecting the USB port and hadn’t noticed it wasn’t being charged. I’m not really sure what position you’d have to be in to see them.

The quality of the USB connector is acceptable, it seems like the inside edge is being squished a little or it was deformed in the building process, possibly just a cheap connector. It might straighten out/loosen up during use.

 

Construction is pretty good and seems solid enough. I’m not in love with the colour of the bezel though, makes me think circa 1987 IBM.

 

Boot times are decently fast, as are shutdown/resumes (but it is a fresh install of XP)

1m 23s for a full reboot after a windows update. (wireless not connected)

32s -35s for a full shutdown (seems like something is causing a delay, maybe the wireless card ? )

48s for switch on to CubeUI (wireless not connected)

Standy is around 5 seconds as advertised, things get connected and disconnected the familiar USB beep, hopefully its not any of the drivers that upset software during a standby, some poorly written drivers/software don’t see the windows power message that its going into standby and disconnect.

 

I always seem to have some issues with certain wireless cards (usually Atheros) and the Linksys N router i use, it’ll fail to connect properly the first time, disconnect and reconnect works though. My Acer aspire one A150 did this as well, until I replaced the wireless card with an Intel unit. This machine uses a Marvell sd8686. Intel cards are great… Superliminal message.

 

The brightness level I changed from 50% to 100% didn’t seem to survive a reboot/shutdown, tried it a few times, if you set the vilivManager to auto load it sets the brightness.

image

 

Usual Crap

Doesn’t have the usual plethora of crap installed, but it does have the K Lite codec  pack installed, I think codec packs are evil so that has to go. Has an Office 60 day trial, and a few oddly named viliv apps, the usual stuff, music player, settings, GPS control, shortcuts to websites. All the live stuff seems to be installed as well. Pretty happy with the level of clutter, its no where near the usual levels. I suspect that has something to do with Dynamism though, I’ve bought from them before, the superb Sony Vaio X505.

 

Not sure what FastWEB is yet, since its still ‘connecting…’ for about 5 minutes, aha the wireless card has disappeared, I set the default in the viliv manager looking for a way to set the brightness levels permanently and it turns off the wireless/bluetooth as default, which since i can’t see the LED, i didn’t know ( yes yes i know, the icon coral). Now that the wireless is back on again FastWeb is a clunky little mobile-ish browser, very basic and not that Fast, though to be fair they’re not specifying what aspect of the Web it is designed to make ‘Fast’, it could be that the idle loop is now 500% faster. Though I suspect it’ll take slightly more than that to fulfill my dream of real mobile internet, whatever that is. But I am intrigued with the claim that i can enjoy it wherever and whenever, perhaps there is more to this device than meets the eye, maybe that provided I/O port beams more than PowerPoint’s, I just hope the GPS is accurate. Its also been a long time since I’ve seen a browser advertised with full ActiveX functionality, if ever.

 

FastWEB, the irony.

image 

 

If they called it SuitableForThisFormFactorWEB it’d be a lot more accurate, but a terrible name.

 

 

DSC01982

As usual with any glossy touch screen, fingerprints are everywhere already, at least we hope they’re fingerprints.

 

I’d like to get hold of that giant X70 that Viliv uses in the brochure, or get hold of the tiny girl operator whom i reckon to be about 8 inches tall, either works.

The GPS switch software changes the baud rate of the GPS from 4800 to 9600 bps, basic stuff would be nice if it had the usual number of satellites, coordinates etc. I may just not have found it yet.

The soft keyboard is a nice touch, translucent split keyboard that pops up at the press of the semi-dedicated button, the buttons light up after you touch them which seems odd to me, presumably the light is to let me know which buttons do what, but only after I’ve pressed one.  Maybe another application for the webcam ?

Soft keyboard

image

The back lighting on the buttons is a bit patchy or misaligned on some of the buttons, A is the worst. the MENU has a very bright bottom left of the M and _ of the  U , but dark in the middle. It is bright enough to be distracting. LED timeout is very short, so hopefully there is an overriding setting. Extra buttons for C and FN, the C button brings up the music player, seems like the default mode of this device is to bring up the music player.

 

Music Player

image

The task bar is set to auto hide, I typically do use this setting but on a touch screen it can be easily be calibrated so you can’t get down there and activate it, something I’ve had on most of my touchscreen computers. The menu button on the right can pop up the start menu, now for FN.

 

vilivCAM seems ok, basic stuff. The camera is on the right side, so its showing an offset picture, it’d be nice if it were tilted a tad so that its looking a bit more directly at you for video conference etc. Typically the cameras are above the screen ( and with a tilt again on the Sony TR series, which even has a mirror ), but no space here. Quality is decent enough, can’t imagine why I’d ever use it though so maybe make it double as a light sensor for setting the brightness levels in dark/light rooms ?

 

webcam looking at an iPhone.

image

 

I clicked on something called i-viliv for MID and it started downloading a setup program, the install screen gives no clues, then it shows ‘error creating uninstall information’, on completion it turns out to be an update manager. There is me thinking its MIDI software. So far it is updating the graphics driver (28mb zip file @ 31KB/s rx !) and touch screen. Adobe AIR also popped up in the background with an update of its own, then asked me to close the CubeUI. So its probably a shockwave/flash application.

image

 

 

The uiCube thing seems ok, if you hit a blank button it loads the music player. Basically its just a pretty shortcut front end, you could do something similar with a grouped icon list ( and use iconid to hide them ), but its a bit more stylish.

 

 

Nothing I’ve seen yet actually uses the GPS, only the baud rate toggle. To test it I can grab NetStumbler or Google Earth and see what happens. GE complains about the low resolution < 1024×768, then about switching to DirectX mode, it runs well enough. Though I just remembered live GPS only, since its still downloading the updates I shall hold off on NS since it might upset the wireless connection. No minimise button on the update app, so windows+d takes care of it. Playing around with GE its decent enough. The update rate is fine, the low image resolution doesn’t seem to be causing me any problems. It is of course an Intel GMA mobile chipset,  set to 32bit 1024×600/60 hertz.  I wonder if GMABooster will work ?

 

IE7 with the SSD is plenty fast enough, it feels sluggish on my Aspire one A150 HD version, but snappy on the Viliv, lets see GMABooster, Intel 950, downloading 2.0c, run, install, click, agree, click, click, click, GMABooster thinks my hardware might not be supported! Check specs, dynamism, nope, myviliv, lots of surprised and odd looking girls, pleasure of 5.5 hours, joyful multimedia, some more odd direction, yes just smile like that, and finally the tech specs, its WSVGA with a touch screen… ok off to windows control panel which is severely lacking in surprised marketing girls but it has the required capabilities for 5.5 hours of pleasure..

So it is an Intel GMA 500. 8086 / 8108, blah, therefore GMABooster doesn’t support it, yet.

The on screen keyboard generates some hum when you use it, now i could just be wrong and its actually a ‘beep’, but otherwise it does work well. Aha, coming back to this, is this the ‘haptic’ keyboard that i just read about from the odd smiles in the brochure, hah yes it is, it’s actually vibrating, maybe a teeny mobile phone motor or sound ?

Oh dear, that may upset someone, “Did you like the new joyful experience of the haptic  keyboard”, or did you just think it was electrical noise.

 

So far it seems like a decent device, most of the negative comments above are simply just setting up, marginal wireless cards and getting to know it, nothing really stands out as bad (unless the windshield mount is really meant to be like that) , I didn’t read a manual, nor did i see one beyond the quick start.

Once its all setup and in the car I’ll take some sunlight readability pictures. Presuming the thing doesn’t fall of the mount, which I’m convinced is something that I missed or its just misaligned.

 

Note that dynamism are really excellent at spotting a lot of these things, they mention things like the wireless card (and driver versions to use), default wifi/bt off etc.

 

They seem pretty hip to what people want to use this device for, Hulu, StreetDeck and Google Earth are all mentioned. Instant on, (5 seconds) , long battery life, size and 3G (Premium only) are the big selling points.

Xmas will be around before the i-viliv update* thing is completed, so I shall come back to this later and apparently I’ve just won the “Spanish Online Cyber Lottery award program”, so I’m guessing they’re too busy spamming to watch Futurama , or are they ?

 

*Fabulous the updater failed, and no resume, time to Google for that filename.

 

Day 2

I’ve discovered the following things, the power cord seems to be really tight but twice now I’ve found its disconnected itself, so the battery ran down and instead of windows going into standby its just switched off. The power settings are correct, maybe the alarm level has to be pushed up a bit. Hibernation is off since it needs 1.5Gb of disk space and standby is supposed to be really good on this device.

 

StreetDeck is annoying, the GPS is awkward to setup up ( i left the unit outside for 40 minutes! ) so i downloaded a couple of GPS tools until i found EarthBridge which gives Google Earth free edition a real-time GPS of sorts, but more importantly just tells you if the GPS is working, number of satellites etc. The GPS unit seems pretty good, it’d get a lock from inside the house near a window too, even with the GPS having a verified fix StreetDeck still whined, their installer does a self verify and at 1.2GB that takes a long long time, especially doing it over the wireless connection (hours), plus i could never actually get it to show me the map nav screen, presumably it needs to be licensed and not the demo? Anyway I gave up with it as it honestly doesn’t seem that great an application, a NAV system that has so much problems setting up a simple GPS connection sets off warning bells, I did do the ‘Not Set’ and left it for plenty of time to auto detect and nada, plugged in EarthBridge and it fired up immediately.

 

EarthBridge with Google Earth, no lock since I’m inside or there’s been a terrible disaster and Las Vegas is now underwater. Very useful for checking the GPS though.

image

 

Somehow I’ve broken Cube, I refused Adobe Air to update and since then it won’t load, not a huge loss. I’m sure if i update Air, though it hasn’t asked me again, it’ll work. (Its alive again, though I don’t know why)

 

There is a 4.98GB EISA partition, no doubt with the windows recovery , but 5GB ? Time to break out an XP setup disk or Partition Magic and delete that. Especially since you only get 9.93GB and I’ve only got about 3GB usable, which has me wondering where a lot is, no doubt a 1.5GB pagefile at least and Windows. I may turn off the pagefile altogether. Ahh how i miss CD’s, yes i know the device has no CD drive but I’d rather have that 5GB of space thanks. How about a bootable USB stick for recovery instead of an EISA partition, no doubt someone could think up of all sorts of nefarious ways to lock down that USB stick so that it can only do recovery, even 16GB sticks are cheap.

image

 

Wireless

The wireless speed isn’t great, on speedtest.net i get

2.04Mb/s / 1.42Mb/s @ 48Mbps

My desktop is

23.08Mbps / 2.57s wired

12.48Mbps / 2.39Mbps wireless using the onboard RTL8187 , disabled wired connection, same distance from router.

Later I’ll test one of my USB wireless adapters and see what it does, sometimes the speedtest apps are a test of the CPU/disk much as as the internet connection.

 

Back to this and the wireless speed seems very wrong, popped the alfa 500mW usb on there instead, a quick windows update and its alive, already its quicker just on showing me the available wireless stations. Connection is quicker too. Back to speedtest after disabling the onboard wireless.

Alfa AUS036H

2.50Mb/s and 2.99Mbps which is odd, checking the connection speed it says 11Mbps, so it could be the usb hub i had to use since the X70 only has one regular USB slot (though its still an improvement even though its a lower reported speed)

With the Alfa connected directly to the X70, the speeds are different. 4.94Mb/s and 0.64Mb/s…. which only goes to show that (A) Radio The Shack hub’s suck, (B) Speedtests are dependant on network load(duh), but almost 5Mb’/s is the best I’ve seen on wireless download so far, and whoops the adapter connected to the neighbours’ open wireless connection, so that is why speedtest was showing Embarq…

 

A quick retest and we’re at 8.06Mb/s and 2.42Mb/s, so mystery over, the onboard wireless of the X70 just isn’t that good, and when you switch USB ports in windows for a wireless adapter, make sure its connected to the right access point before running tests and yelling at other people to get off the network while you run said tests.

 

For reference my Acer Aspire One A150 with the Intel card does 13.85Mb/s and 1.90Mb/s , but it is a 4965AGN so its bound to be better, though I do not have the 3rd antennae connected.

 

Remarks

I did finally get the Viliv update tool to download the Touch app update for 6Mb @1-10Kb a second, which is really really slow, Amiga modem slow. Perhaps all the new X70 owners are downloading the update, or they’re running the update servers off the X70 itself.

The windows tooltip balloons drive me nuts, especially on a touch screen. Do I care if my wired network connection is disconnected , when its never been connected. Especially for 60+ seconds. Now I can run Microsoft’s FixIt application at 636KB or the < 100 byte registry file which oddly MS doesn’t give you in the fix it yourself section, HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced add DWORD of

EnableBalloonTips 0 

Which has always struck me as odd, a setting that typically doesn’t exist is called Enable, how about DisableBalloonTips with a value of Anything at all. I think TweakUI handles this one too. Needs a restart to enable the disable.

This reminds me of another issue, not sure if its related just to Safari but typing in with the virtual keyboard in the Google Search box in Safari gets Google to list out the things it thinks you’re going to be looking for, and it works pretty well, however it blocks the virtual keyboard ! I also could never select one of the suggestions, it’d just search for the partial phrase already typed in (probably that last bit is Safari). Now it is allowing the keyboard to stay at the top level, this seems like a recurring theme.

Changed the power setting to switch to standby when the power button is pushed, we’ll see how that works out.

Since I updated the touch screen software apparently there are two instances running, so two icons in the coral. Maybe one for each screen of the one screen I have ? Task manager shows two of xTouchMon.exe

Otherwise I’m pretty happy with it, the screen is nice and clear, the resolution is good, its a snappy loader ( SSD ) the keyboard is useable, form factor is ok. Be nice to be able to see the leds and switches though, might be a design decision for less clutter but at least have a hint of the colour. Lots of bleed on the wireless/HDD LED, a simple separator would have cured that.

The pungent case smell has diminished a fair bit, so its either a manufacturing process or material that just needs to off gas.

This form factor you just accept there are going to be things that you just have to live with, though I’m pretty happy. Its like a big Nokia 8xx with Windows.

Its a lot more useable than the Sony UX180 due to the size, that is why I waited on the 7” version.

There is an interesting looking plastic cover under the battery…. How long before the warranty gets voided I wonder? 3G slot perhaps, since I didn’t get the premium edition.

I have not been able to get into the BIOS screen with the menu/bios logo combination, regardless of how i try it.. So it might be a tricky one.

A few people have already come across this entry by looking for x70 wireless disconnect and the like, check out the FAQ page at dynamism x70 page for the recommended driver to use. (4/25/07 (version 8.75.706.701).)  http://www.dynamism.com/#Product=viliv_x70 FAQ , near the bottom.

Advertisements